Virtual card details not loading
Incident Report for Airbase
Resolved
This incident has been resolved.
Posted Oct 21, 2021 - 11:57 PDT
Identified
The ability to view and copy your virtual card details is currently unavailable. This is due to one of our card providers experiencing an outage and we are working with them to resolve the issue as soon as possible. Transactions and other functions within Airbase have not been impacted.
Posted Oct 21, 2021 - 10:18 PDT
This incident affected: Airbase Cards.