Intermittent issues across multiple platform components

Incident Report for Airbase

Update

We are actively monitoring intermittent issues related to one of our infrastructure providers. Some users may continue to experience disruptions while navigating and using the Airbase platform.

Mitigation efforts are underway, and our provider is reporting steady improvements in overall performance. We will continue to monitor the situation closely and share updates as needed.
Posted Oct 20, 2025 - 11:57 PDT

Monitoring

We are actively monitoring intermittent issues stemming from one of our infrastructure providers. As a result, some users may experience disruptions while navigating and using the Airbase platform.
Posted Oct 20, 2025 - 07:13 PDT
This incident affects: Airbase Dashboard and Airbase Cards.