The Airbase dashboard is inaccessible.

Incident Report for Airbase

Resolved

The incident has been fully resolved. Users should no longer experience any issues accessing the Airbase dashboard.
Posted Mar 11, 2025 - 10:49 PDT

Monitoring

Our engineers have identified and resolved this issue. Users should now be able to access the Airbase dashboard. We will continue to monitor this incident and provide additional updates as needed.
Posted Mar 11, 2025 - 10:19 PDT

Investigating

We have received reports that the Airbase dashboard is inaccessible. Our engineers are investigating and we will provide another update soon.
Posted Mar 11, 2025 - 09:30 PDT
This incident affected: Airbase Dashboard.