Issues with upstream DNS provider
Incident Report for Airbase
Resolved
The incident has been resolved.
Posted Aug 23, 2022 - 18:45 PDT
Identified
We are investigating an issue with an upstream DNS provider. The dashboard is inaccessible for some users. We are currently working to fix the issue.
Posted Aug 23, 2022 - 16:50 PDT
This incident affected: Airbase Dashboard.